Anaconda Install or Update TensorFlow to Specific Version – TensorFlow Tutorial

By | November 7, 2019

We can use anaconda to install tensorflow, here is tutorial.

A Beginner’s Guide to Use Anaconda to Install TensorFlow on Win 10

However, anaconda may install tensorflow 1.2.1 version defautly, if you want to update or install tensorflow to a specific version, how to do? In this tutorial, we will introduce you how to do with anaconda.

First, you should activate your python environment

As to us, we have installed python 3.5 in py3 environment, we should activate it.

activate py3

Check tensorflow versions you can do

We can use conda command below to check what tensorflow versions you can installed.

conda search tensorflow

The result is:

conda search tensorflow

As to us, we have installed tensorflow 1.2.1, we will install tensorflow 1.5.1 version.

From above, we can find python 3.5 supports tensorflow 1.5.1 and anaconda channel is conda-forge.

Reinstall tensorflow 1.5.1

conda update command can not update a package to a specific version, we have to reinstall it.

conda install -c conda-forge --force-reinstall tensorflow=1.5.1

Then we will find:

tensorflow 1.2.1 update to 1.5.1

Then, we will install tensorflow 1.5.1 on my python environment.

However, if you run tensorflow application occur error: AttributeError: cffi library ‘_openssl’ has no function, constant or global variable named ‘Cryptography_HAS_NETBSD_D1_METH’, you can read this tutorial to fix it.

Fix AttributeError: cffi library ‘_openssl’ has no function, constant or global variable named ‘Cryptography_HAS_ECDH’

Leave a Reply

Your email address will not be published. Required fields are marked *