Fix nasm/yasm not found or too old. Use –disable-x86asm for a crippled build Error – Linux Tutorial

By | July 22, 2022

When we are installing ffmpeg in linux, we may get this error: nasm/yasm not found or too old. Use –disable-x86asm for a crippled build. In this tutorial, we will introduce you how to fix it.

This error looks like:

fix nasm yasm not found or too old. Use --disable-x86asm for a crippled build

How to fix nasm/yasm error?

We can fix this error by these steps.

Step 1: download yasm 1.3.0 for linux

We can download it in here:

http://www.tortall.net/projects/yasm/releases/

download yasm 1.3.0 for linux

Step 2: run commands below one by one

tar zxvf yasm-1.3.0.tar.gz

cd yasm-1.3.0

./configure

make

make install

Then, we will find this error is fixed.

step guide to install yasm