Fix Python Pyemd Installation Error: Microsoft Visual C++ 14.0 is required

By | October 31, 2019

Python pyemd package can help us to calculate word mover’s distance, however, when you are installing it, you may encounter an error: Microsoft Visual C++ 14.0 is required. In this tutorial, we will introduce you how to fix this error.

Use pip to isntall pyemd

pip install pyemd

Then you may find an error like this.

install pyemd find microsoft wisual c++ required error

How to fix this error?

You can install a .whl file to install.

Open url: https://www.lfd.uci.edu/~gohlke/pythonlibs/#pyemd

Then you can select a pyemd version to download and install.

As to us, we are using python 3.5 on windows 10.

install pyemd on python 3.5

We will downloand pyemd‑0.5.1‑cp35‑cp35m‑win_amd64.whl  to install

Install pyemd whl file

We also use pip command to install

pip install e:\pyemd-0.5.1-cp35-cp35m-win_amd64.whl

Then we test and python pyemd library has been installed successfully.

Leave a Reply

Your email address will not be published. Required fields are marked *